• Publicité

messages

Une question sur une application, c'est ici

messages

Messagede SnowMonkeN » Dim 16 Aoû 2009 18:19

Bonjour,

Alors voilà mon petit soucis avec l'appli "Messages" c'est lors de la réception de sms sur un autre mobile, la lecture n'est pas toujours possible. J'ai testé sur plusieurs mobiles.
Je m'explique. J'écris un sms des plus simple et à l'autre bout la personne reçoit des petits carrés à la place ou des caractères spéciaux. Parfois elle a le début du message et la fin ce sont des petits carrés ou @ ;-) et parfois c'est le contraire ;-)
Voilà ce que j'ai remarqué, alors je voulais savoir si vous avez eu aussi ces petits bugs soit avec le HTC hero ou un autre mobile sous Android ?

Petit exemple de message:

Message écrit : "Hello, comment vas-tu la forme ? Que fais-tu ce soir"
Message reçu : "Hello, c@o@m@m@e@n@t v@a@s-tu la forme ? ..." (Assez sympa comme message non ? ;-))
Xubuntu 13.10
Mac OS X 10.9
Et un tit peu de Windows XP/7/8, et oui pas le choix
Xiaomi Mi3 (4.4)
SnowMonkeN
 
Messages: 238
Inscription: Mer 12 Aoû 2009 12:35
Localisation: On the Web pk ? ;-) (Vaud, CH)

Re: messages

Messagede Tostaki » Mar 18 Aoû 2009 00:48

Je n'ai jamais remarqué ce souci.
Quels étaient les mobiles de destination que je tente aussi l'expérience ?

A++
Google Galaxy Nexus 4.0.2 Stock
Ubuntu 10.10
Un peu de Windows XP/7
----------------------------------

Avatar de l’utilisateur
Tostaki
 
Messages: 4565
Inscription: Lun 13 Avr 2009 01:00

Re: messages

Messagede SnowMonkeN » Mar 18 Aoû 2009 07:12

Alors j'ai testé juste sur des SonyEricsson (W810 et W880), je n'en avais pas d'autres sous la main. Mais je verrais si j'ai un retour de quelqu'un qui en a un autres.
Xubuntu 13.10
Mac OS X 10.9
Et un tit peu de Windows XP/7/8, et oui pas le choix
Xiaomi Mi3 (4.4)
SnowMonkeN
 
Messages: 238
Inscription: Mer 12 Aoû 2009 12:35
Localisation: On the Web pk ? ;-) (Vaud, CH)

Re: messages

Messagede Tostaki » Mar 18 Aoû 2009 10:55

Je viens de faire le test depuis le Hero vers un SE W880i

Rien à dire, tout est passé correctement.
Réseaux utilisés : SFR vers Orange FR
Google Galaxy Nexus 4.0.2 Stock
Ubuntu 10.10
Un peu de Windows XP/7
----------------------------------

Avatar de l’utilisateur
Tostaki
 
Messages: 4565
Inscription: Lun 13 Avr 2009 01:00

Re: messages

Messagede SnowMonkeN » Mar 18 Aoû 2009 17:24

Ok alors, merci bien d'avoir testé. Moi c'était entre opérateur Sunrise (Suisse). Sans doute un bug de passage. Je verrais par la suite.

Image
SnowMonkeN
 
Messages: 238
Inscription: Mer 12 Aoû 2009 12:35
Localisation: On the Web pk ? ;-) (Vaud, CH)

Re: messages

Messagede SnowMonkeN » Ven 28 Aoû 2009 07:18

Bon et bien ce n'est pas un bug de passage ça continue. J'ai testé sur un samsung, un nokia, un iPhone 3GS et bien de temps en temps une partie du message est illisible. Donc hop je dois re envoyer, comme ça l'opérateur sera content avec le double de messages ;-) M'en fou j'ai un forfait 1'000 messages ;-)

Alors j'ai regardé avec mon frère qui a un Magic et bien quand il met des accents circonflexes la personne qui reçoit le sms a des caractères spéciaux. Donc je pense que c'est plus lié à android. Pour ma part c'est avec n'importe quoi comme message même sans accents. Toujours personne n'a constaté le soucis ?

Salutations

SnowMo
Xubuntu 13.10
Mac OS X 10.9
Et un tit peu de Windows XP/7/8, et oui pas le choix
Xiaomi Mi3 (4.4)
SnowMonkeN
 
Messages: 238
Inscription: Mer 12 Aoû 2009 12:35
Localisation: On the Web pk ? ;-) (Vaud, CH)

Re: messages

Messagede SnowMonkeN » Ven 28 Aoû 2009 07:46

Bon et bien je me réponds à moi même ce n'est pas un bug c'est juste une soucis d'encodage des sms.
Il existe différentes normes :
La norme GSM
La norme UTF-16

La norme GSM gère bien l'UTF-16 sur le premier SMS mais dès le deuxième il y a des soucis d'interprétation.

La norme UTF-16 est sur 2 octets et commence généralement avec un zéro et la conversion de 0 en alphabet GSM donne @
C'est pour ça que les personnes reçoivent le @ avant chaque lettre du mot : @s@a@l@u@t ;-)
Et on arrive très vite à la longueur max du message (160 caractères).
UTF-16
160 caractères - 20 pour l'en-tête (qui donne la norme du codage) / 2 (et oui c'est sur 2 octets) = 70 caractères pour ton premier message ce qui est court ;-)

Voilà en gros l'explication pour le message illisible. Alors pour palier à ce soucis écrivez sans accents ;-) ou ayaez à portée de main l'alphabet GSM ;-)

Salutations

SnowMo

PS: je n'ai pas trouvé tout seul ;-), j'ai juste fais un petit résumé de ce que j'ai pu trouver sur divers sites
Xubuntu 13.10
Mac OS X 10.9
Et un tit peu de Windows XP/7/8, et oui pas le choix
Xiaomi Mi3 (4.4)
SnowMonkeN
 
Messages: 238
Inscription: Mer 12 Aoû 2009 12:35
Localisation: On the Web pk ? ;-) (Vaud, CH)

Re: messages

Messagede Tostaki » Ven 28 Aoû 2009 09:59

le grand classique mais ce qui m'étonne, c'est que par défaut, l'UTF 16 n'est normalement pas utilisé.
L'UTF8 l'est dans la plupart des cas.
Google Galaxy Nexus 4.0.2 Stock
Ubuntu 10.10
Un peu de Windows XP/7
----------------------------------

Avatar de l’utilisateur
Tostaki
 
Messages: 4565
Inscription: Lun 13 Avr 2009 01:00


Retourner vers Applications

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 0 invités

  • Publicité